Find User here you can look for a user

Trouble building

#1 2017-12-07 04:31:50
I'm having trouble placing buildings my villagers do not seem to want to build the building I am putting down and I have well over the required supplies am I doing something wrong or is it a glitch ?
#2 2017-12-07 11:17:47
might have to actually click on them and move them to the build site.
#3 2017-12-10 13:39:33
sometimes it takes them a while to move to the building site, ive noticed. Its very annoying
Leader of the First Future Federation. Join us for a great MyColony and Antiquitas support community!
discord.gg/fr7sHpt
#4 2017-12-13 05:31:16
I have the same problem. I have to go figure out what servant is required and then manually move them.

It's my biggest frustration right now.

Otherwise - I'm having fun with the new game!
#5 2017-12-20 17:16:12
I've had some limited success with this with not having anyone harvest. Instead, I will select all the servants of a type and then click on the mine, etc... This seems to help sometimes.

That said - this is very frustrating. In this game, I have to manage all the resource gathering and creation of mines, food, etc. It's often tough to find the right servant - especially as they look similar and have names that I've yet to memorize. So, what I usually do is when I need a servant of a type, I build a new one. I'm starting to accumulate lots of servants.

It would be great to fix this. It works just fine in My Colony - so I'm hoping that this can be easily corrected.

Syndication