Find User here you can look for a user

Lagging. Bad game optimization or what?

#1 2018-04-11 12:50:11
This is awful. Game is so slow. Always lagging. I have not bad PC at all ( Intel I7, Nvidia 1080ti...) I have for now only 200k colonists, but it is harder and harder to play... It is so funny, because I have no problems with no one "AAA" game on Ultra settings. Perhaps, developers should pay special attention to optimizing calculations in the game? I like this game, i wanna play it, but i can't - it lags! And yes, of course, I set all the settings for the minimum - nothing happens.
Please, do something!
#2 2018-04-11 13:17:57
If you are on the Windows Store version of the game, it tends to run a lot slower. Try the Native Client or Launcher version from here:
https://market.ape-apps.com/my-colony.html
Owner of Ape Apps
#3 2018-04-11 14:39:34
Just one developer, Bast, who replied above. Game has been improved significantly and is, admittedly, constantly in Beta.

You may have already, but make sure:

1. Every building has access to a blank or road space. If workers can't get to a building, it will cause more lag.
2. Rovers you don't need are destroyed
3. No rovers are stuck in buildings
4. You don't have a massive forest of a resource that expands (trees, sugarcane, etc).

200k is not an insignificant number of colonists either.
Human Colony Charter: pTfi0Opt
Insectoid Charter: EXFzp37s
#4 2018-04-11 14:48:59
Thank you very much mister Bastecklein :) I hope it will help ))) But when i launched client i've lost my main save. 2 or 3 weeks to the tail. LOL. The game is wonderful, it's never too late to start again [cries].



Sorry, i've just imported my main save! Great! Thank you guys!
Edited by XNesh on 2018-04-11 14:51:13
#5 2018-04-11 15:01:03
Hmmmm.... Now i see that it helps not too much. Still lagging. JaxxSilva - every building in my colony has access to road. Quantity of rovers is 165. I cut down the whole forest. No rovers are stuck in buildings.
But i have more than 5k of diamond solar towers - can it be a problem?
#6 2018-04-11 15:22:01
XNesh said:Hmmmm.... Now i see that it helps not too much. Still lagging. JaxxSilva - every building in my colony has access to road. Quantity of rovers is 165. I cut down the whole forest. No rovers are stuck in buildings.
But i have more than 5k of diamond solar towers - can it be a problem?


I wouldn't think that would be a problem, but I have not been able to figure out if buildings that do not need employees need access to a blank/road tile or not. I typically build with access just to be safe.

I have a few colonies at about 150k pop. There is definitely some lag on them even at the more optimized settings. I've found that a periodic fire drill helps me - but some people swear up and down that it breaks their colonies - so proceed with caution there.

Also, if you leave your game running for hours at a time, it seems to help to exit back to main screen and re-log in periodically. Again, that's anecdotal, but seems to help me.

I'm afraid that about wraps up my best ideas, hope one of them helps to some degree!
Human Colony Charter: pTfi0Opt
Insectoid Charter: EXFzp37s
#7 2018-04-11 17:20:12
thanks man, it does not work. I think that problem is in optimization of calculations in game. Maybe engine is not perfect. Sad.
#8 2018-04-11 17:35:29
It is hard to tell if there is something special with your colony or what is causing the lag. My largest colony is 96k people and it runs like butter. In theory, after 2k colonists, colonists no longer cause any noticeable lag as they are virtualized.

One thing that causes the most lag is if you have expanded your map size several times, especially if it was already large to begin with, as the pathfinding algorithms get exponentially slower as you increase the size of your map (I even put a performance warning on the 'annex land' policy because of this).

Is your map in Online mode of Offline mode?
Owner of Ape Apps
#9 2018-04-11 17:40:06
I increased the size of the land 3 times. Online mode. I checked with running game - CPU is loaded maximum at 20%. There is no problem with hardware.
#10 2018-04-11 18:22:57
If you can load your colony in the Google Chrome browser on the web version of the game ( https://www.apewebapps.com/my-colony/ ), you can open the Developer Tools, go to the Performance Tab, and record a short (about 20 seconds) performance profile. It will indicate which functions are lagging out on your map
Owner of Ape Apps
My Colony

#my-colony


#my-colony-podcast
Welcome
Ape Apps is an independent software development company founded in 2010 by Brandon Stecklein. Over the years, Ape Apps has published over 400 apps and games across various platforms. You can get in touch with Brandon on Twitter or by leaving a post on his wall @bastecklein
App of the Day