Find User here you can look for a user

Android 1.0.0 just updated bots building problem

#1 2019-12-21 01:57:38
Android 1.0.0 just found that update you should be able to reproduce this easy .
Place a building say a 26 colonists house to be built say 20 tiles from bots and watch the bots apire as if from the unbuilt house then go repark and repeat over and over never accutly building the building. But if you select the bots then direct them they then build .
Ps on a new city with only rovers the rovers will go back and forth a few times then eventually build and they go through buildings as if the building is not there .
This one every one will see as this phone is accutly a better phone and new .
#2 2019-12-21 02:29:25
@colbya can you go to engine settings and change the pathfinding to 'multithreaded - on' and see if that changes it?
Owner of Ape Apps
#3 2019-12-21 02:35:33
Yep that worked bots now acting normal .ps good thinking .
#4 2019-12-21 02:44:46
I noticed it on mine too. Next update I am going to switch multi-threaded pathfinding to 'on' as default.
Owner of Ape Apps
#5 2019-12-21 14:46:24
I had a bot mining problem tonight. I have about 37 regolith miners grouped together in a single stack. I couldn't seem to mine enough regolith to feed my usage. After ungrouping them into 37 individual rovers I suddenly had no problem feeding my usage (as in, I built a stockpile of thousands in a matter of seconds). If I can reproduce the issue I'll write up how.

Right now I have the population reset bug which is a bit more pressing to deal with.
#6 2019-12-21 21:07:17
That's why I don't like bot stacking for rovers other than builders
Elijah Long
Edited by Eli45610 on 2019-12-21 21:09:10
#7 2019-12-27 17:21:49
yea the bot stacking is new and as of now only works with builders BUT that is a BIG huge only as 90 % of the lag caused by bots is reduced just by stacking builders .
now me I just use region and two or 3 city mining which meens i only go into them to place mines . The bots will then mine wile your in another city getting ride of lag caused by miner bots .
I also use one or two citys for storage like building the buildings that give bandwidth as they do nothing but provide storage for it and to gte enough bandwidth it takes 100 S
#8 2019-12-27 19:49:58
So i think I might have some analysis on the issue. It will appear next to the item it will need to build in question and then have as it's final destination the position it was just at. Then when it reaches the new point it repeats. By small increments it will position the start and endpoints closer together. I think it's somehow switching start and end points, possibly a switch in a variable where it takes the address of the final point and the starting point. Course I don't know the specific code but I hope this helps. Oh incidentally this was on PC
My Colony

#my-colony


#my-colony-podcast
Welcome
Ape Apps is an independent software development company founded in 2010 by Brandon Stecklein. Over the years, Ape Apps has published over 400 apps and games across various platforms. You can get in touch with Brandon on Twitter or by leaving a post on his wall @bastecklein
App of the Day