Find User here you can look for a user

Colony saving issue

#1 2020-01-07 02:35:42
Dear Bast,

I have an issue with my colony seemingly saving successfully, yet the state of the colony always reverts to an earlier save point, no matter what changes I made in the colony.

I play in PC browser (Firefox), single map colony, cloud save never enabled, online game.

Chronologically the issue happens as follows :
- Last successful login : Thursday 2 January (right before the major downtime issue).
- On Friday 3 January, was able log in into my Ape account via browser, but whenever I tried to load the save the following message appears :
"Unable to connect to the My Colony Server. Games in online mode require an Internet connection to play. There was an error parsing server login response. Please try again." After a few tries, I did not pursue it further for fear of corruption.
- On Monday 6 January, was able to finally load the game. Played a few hours, made some changes, saved, and exited. A few hours came back to load the game, save reverted back to the Thursday 2 January save, and all colony changes made earlier today was as if they never happened. OK, tried making smaller changes, let the game idle for an hour or so, saved successfully, and exited. Loaded the game back, all changes wiped.
- Tried in total of 5 trials to load the game and make changes, with the same end result even after idling the game for some time and saving. In essence, the game would not save any further changes and always reverted to the 2 January save.

Is there a way to solve this issue and save my colony? Thank you beforehand.
#2 2020-01-07 18:52:00
Sorry everybody, this saving issue should be fixed, but you might have to do an empty cache/hard reload for the update. This was impacting all non-cloud sync colonies, as there was an error in the way data was being saved to the browser.
Owner of Ape Apps
#3 2020-01-07 19:30:08
I have just open the 1.2 beta, and the save problem seems solved.
#4 2020-01-08 16:59:35
Dear Bast,

I can also confirm that the saving issue seems to have been fixed in the latest stable version of 1.1.0.
Thank you for the prompt action.
#5 2020-01-22 20:22:25
I am on Windows 10 playing version 1.2.0. I switched off syncing to the cloud after I lost two days of play. Syncing, however keeps reactivating: I get the onscreen message "Syncing to the cloud." As soon as that happens the game reverts some cities to a state from a couple of weeks ago, while others retain the most recent changes. Today it also erased the last new city I built, 2/3 of my colonists, 2T in money and 5k starships. I am not amused.

When I checked the syncing state on the region map I found:



Clicking on Cloud Sync does nothing: it remains "On".
Clicking on Game Save Compression changes it form "Off" to "On", but at the same time Cloud Sync disappears:



Clicking Game Save Compression again switches it back to "Off," but Cloud Sync remains missing.

When I now open one of my cities and check compression and syncing I get:



and everything acts the same as for the region map. When I return to the region map form any of my cities it has reverted to the state in the first picture.



My Colony

#my-colony


#my-colony-podcast
Welcome
Ape Apps is an independent software development company founded in 2010 by Brandon Stecklein. Over the years, Ape Apps has published over 400 apps and games across various platforms. You can get in touch with Brandon on Twitter or by leaving a post on his wall @bastecklein
App of the Day