Find User here you can look for a user

Paying colonists causes game to freeze for a long time (payroll and stimulus)

#1 2019-01-03 22:33:53
Just as the title says, whenever it comes time to pay colonists, the game will freeze for as long as 2 minutes before resuming like normal. (I've also experienced as long as 3-5ish minutes) The same thing happens when issuing a stimulus package, but the freeze doesn't seem to be as long (as far as I've noticed)

It's gotten worse as my population grows. Probably started at 2,000, and now that I'm just over 9,000 its gotten way worse. Unfortunately i just started playing (again, new account and new game data) so i can't say if its changed with updates.

I've experimented heavily with different performance settings, with little change.

Device: Samsung galaxy s9 (Snapdragon) Android Pie official beta program)
App version: v.0.78.0

Edit: also, as the pay freeze issue has gotten worse, so has colonists not working despite having jobs, being educated, having housing, and having+95% approval.
Edited by nilesandstuff on 2019-01-03 22:35:23
#2 2019-01-04 00:37:15
The game doesn't function that well on mobile but it shouldn't be lagging at only 9000 colonists, for me on pc it's perfectly fine at over a million colonists
#3 2019-01-04 01:48:41
My thoughts exactly. Especially on a newer device like the s9, with plenty of RAM and processor power to spare.

And at most, it My Colony only ever takes up ~300mb of RAM, leaving me with 1.5gb to spare.

Since i don't see other people mentioning this, I'm guessing its probably something specific to Samsung, or more specifically the Samsung implementation of Android Pie.
#4 2019-01-07 14:42:59
I have this problem as well with payroll and stimulus. 34k population, experience freezing for around 5 minutes when payroll triggers.

Details:
My Colony v0.78.0 - LIS Ice World Map Offline (no cell service where I normally play)
Mobile - Moto x4 Android 8.1.0
#5 2019-01-09 15:03:47
I will take a look at the payroll stuff for the next update guys. I remember a long time ago when colonies first started getting real big, the same issue was happening, but I had thought it was addressed. It seems like just suddenly it started happening again on some devices, and I really didn't make any changes to the Payroll code, but I will research it.
Owner of Ape Apps
#6 2019-01-12 20:07:00
So I did some benchmarking and I do not see anything unusual when doing payroll or stimulus. On a population of 153k, I calculated 552ms was required to do a payroll phase. Now I did make some minor changes to the payroll code before running the timing, so it is possible that something I did has improved the situation.

I wonder if there could be something external in the impacted colonies that is having an impact on this, like if there are other stats that are messed up or things not working properly? Have you two noticed anything else strange happening on these maps besides for the slow payroll? @Boolean and @nilesandstuff
Owner of Ape Apps
#7 2019-01-27 17:30:57
Figured i will chime in on this thread vs making a new one. I'm also getting this on my andorid phone (oneplus 6t)

Got a pop of around 30k currently but been getting the awful lag at payroll and stimulus hand outs since around 9k or so. Sometimes up to 5 mins of stall.

It's the current version 0.79.0 and I'm playing on a red planet map with a commonwealth online.

Syndication