Find User here you can look for a user

v0.75.0 Web Pre-Release Errors and Questions

3y
#1
For everyone having bugs with the Web v0.75.0 client, please post them in this thread instead of the Bug Reports area, until the update is actually released to all platforms.

This update is currently getting a complete re-write of all of the online authentication based stuff, so things are likely to be weird. I just don't want to clog up the bug reports with things that are currently in the middle of being redone.

This update is fairly significant and a lot of changes are happening, so if you play on Web I would suggest doing a hard-reload each time you open the game.

I do not expect any game-breaking errors to occur though, as most of the changes are online related.

If you have questions or pre-release bugs specific to v0.75.0, please put them here. And look around, because you will start seeing a lot of neat stuff popping up in this build 🙂
Owner of Ape Apps, LLC
3y
#2
Do you have a rough estimation of when this will be available on the other platforms?
3y
#3
Early next week hopefully
Owner of Ape Apps, LLC
3y
#4
Whenever I go on the statistics or GBT menu, I can see that in the background everything shifts. When I click out of the menu I can see that everything is back to normal.
3y
#5
QQ said:Whenever I go on the statistics or GBT menu, I can see that in the background everything shifts. When I click out of the menu I can see that everything is back to normal.


Yeah, it has been like that for some time. It actually shuts down most of the rendering when some of the menus are open, to improve performance.
Owner of Ape Apps, LLC
3y
#6
I was testing gifts, so I created a draconian desert colony which i would message. I then went on the desert colony, saved and exited the game, and when I clicked on it again, everything was black except the buildings and resources bar. I reloaded the page, and when I tried to enter the Draconian colony again, it said my login credentials were rejected by the server and it asked if I was using a licensed version of the game.
3y
#7
Ok, I will post some of the bugs that need fixing.

First off, my regions game has an issue where cities become inaccessible and the more maps I build the more become inaccessible . This forces me to delete and rebuild them, but that makes a time stamp in the game that the game reverts to when I open it later. When it reverts, it also reverts trading as well.



That's what the console says when it fails to open a city.

The second issue is that any draconian map I make can send receive messages but not send them until the commonwealth leader sends a message and/or gift (I'm not sure which did it as they were both at the same time)

Lastly, as stated above, there are graphical glitches from the stats menu. That also effects the screenshot of your base too, so it's impossible to get a good screenshot.
Hello! I am a High Wizard from the Nations of OZ, come check out our discord server! https://discord.gg/qqCswpF

3y
#8
Did I read federations ?

Edit : compressing a creative map took a very long time, at least way more than it used to.
Edit 2 : save file corrupted after quiting chrome and launching it back
Edit 3 : I selected "load game.." and then the corrupted save, and it loaded normally.

Edit 4 :) Streaming is working fine but we don't see the menus

Edit 5 : Can we have an API for the colonies currently streaming ? I could query each one individually but that wouldn't be very efficient for sure. So an API returning a list would be great!
Creator of Coloniae
Admin of the MC2 translation project
3y
#9
Also, some other things I noticed is that the creative mode doesn't work on regions mode. At all, it just plays like a normal offline game.

Last thing I can see is that there are random consumptions from random resources coming from the regions in the outflow. Even from resources that have no building that consumes them in the game. Which leads me to believe that it carried over construction costs. But considering I've never even used certain resources and they are still being drained from somewhere, I'm not sure what it is thats causing it. This thing is consuming 40k crystal a minute for me... if I wasn't rich this would be a serious problem.
Hello! I am a High Wizard from the Nations of OZ, come check out our discord server! https://discord.gg/qqCswpF

3y
#10
Same, i have just started a new regions in creative mode, but creative mode is not operative. I have create a medium city, harvest some regolith for build 4-5 helium extractor, and zone back in region window. Now i can't enter in the city: "Please wait, region still loading"
My Colony





Welcome
Ape Apps, LLC is an independent software development company founded in 2010 by Brandon Stecklein. Over the years, Ape Apps has published over 400 apps and games across various platforms. You can get in touch with Brandon on Twitter or by leaving a post on his wall @bastecklein
App of the Day